1、下载mysql8.4.4文件取zip文件mysql8.4.4下载路径MySQL 5.7.31详细下载安装配置2、配置环境变量1.系统—高级系统设置—环境变量—系统变量在系统变量中点击新建变量名为量名为MYSQL_HOME添加你的mysql-8.4.4-winx64文件夹所在位置。我的是在E:\Mysql\mysql-8.4.4-winx64如图2.编辑Path复制;%MYSQL_HOME%\bin到原有值的后面3.配置my.ini文件在你的mysql-8.4.4-winx64目录下新建my.ini文件我的是在E:\Mysql\mysql-8.4.4-winx64目录下新建my.ini文件的内容保存后退出[mysqld]#skip-grant-tables#设置3306端口port3306# 设置mysql的安装目录basedirD:\configure\mysql-8.4.4-winx64# 设置mysql数据库的数据的存放目录datadirD:\configure\mysql-8.4.4-winx64\data# 允许最大连接数max_connections200# 服务端使用的字符集character-set-serverutf8# 存储引擎default-storage-engineINNODB#表示 SQL 模式的参数sql_modeNO_ENGINE_SUBSTITUTION,STRICT_TRANS_TABLES[mysql]#编码default-character-setutf84.安装MySQL(1).在输入框内输入cmd以管理员的身份运行注意这里一定一定一定要以管理员的身份运行否则在安装过程中会出现因为管理权限不够而导致的Install/Remove of the Service Denied!安装/卸载服务被拒绝这一点非常重要2执行“mysqld --initialize-insecure”初始化数据库会在data文件夹中生成数据文件3输入安装命令mysqld --install若出现Service successfully installed证明安装成功如出现Install of the Service Denied则说明没有以管理员权限来运行cmd4然后继续输入命令net start mysql出现以下提示证明MySQL启动成功5输入“mysql -u root -p”回车再输入密码例root回车6设置密码执行命令“ALTER USER ‘root’‘localhost’ IDENTIFIED BY ‘YourNewPassword’;”YourNewPassword 这个是密码7可关闭全部窗口进行使用检测忘记 root 密码不能直接执行 alter user因为 alter user 是 mysql 里面的 SQL 语句先要登录进去才行。若没有请看第三条Windows MySQL8.4 重置 root 密码完整操作步骤⚠️全部用管理员身份打开 CMD第 1 步停止 mysql 服务net stop mysql如果提示服务名不对去 windows 服务看真实服务名字比如mysql84就执行net stop mysql84第 2 步新开一个管理员 CMD 窗口不要关闭这个窗口进入 mysql 的 bin 目录执行下面命令windows8.4 必须带上 --shared‑memory否则启动立刻闪退CSDN博…mysqld --console --skip-grant-tables --shared-memory执行之后窗口卡住这个就是跳过密码校验启动 mysql这个窗口不要关保持挂起状态第 3 步再打开【第三个全新管理员 CMD 窗口】免密登录 mysqlmysql -uroot✅现在不需要密码直接进入 mysql 控制台第 4 步非常关键先刷权限mysql8 skip‑grant‑tables 模式下直接执行 alter user 会报错ERROR 1290必须先执行 flush privileges腾讯云flush privileges;第 5 步现在才可以执行修改密码语句alter user rootlocalhost identified by 123456;第 6 步全部做完收尾关闭那两个临时 cmd 窗口运行 mysqld 那个窗口也要关掉正常启动 mysql 服务net start mysql之后就可以用mysql -uroot -p输入新密码123456登录❗常见踩坑说明不要直接普通 cmd一定要管理员权限否则 mysqld 启动失败执行mysqld --console --skip‑grant‑tables --shared‑memory这个窗口不能关闭一关临时 mysql 就停止了忘记flush privileges;直接跑 alter user报 1290 错误不让改密码这是临时应急手段平时千万不要用skip‑grant‑tables启动数据库完全无密码很危险简单逻辑梳理默认情况不知道密码无法登录 mysql无法执行 alter user通过--skip‑grant‑tables方式绕过密码校验启动数据库免密登录进去这时才可以执行 alter user 重置密码3、检查使用1、打开cmd,使用管理员模式2、执行“net start mysql”,打开数据库服务3、执行命令“mysql -u root -p”,回车输入设置的密码YourNewPassword4、执行“use mysql”,进入数据库5、执行“show databases;”可查看现在的数据库初始状态如图证明安装成功6、可安装mysql的可视化软件进行使用软件名称是Navicat Premium 17安装步骤请查看链接